Caldina GTT not boosting properly

The place for all technical car discussions. If you haven't already, read our Disclaimer first!

Moderator: The Mod Squad

Caldina GTT not boosting properly

Postby Technohedge » Sun Sep 10, 2017 6:47 pm

The ol caldina seems to have lost a bit of mojo. Its getting to normal boost pressure, but its not pulling anywhere as much as it used to. Not sure of its taking longer to spool up.

Compression test is fine, wastegate seems to be intact from when i had the downpipe off, seating/sealing well.

The turbine seems to be in good condition, hardly any radial or axial play in the shaft, no smashed up fins and spins freely.

Manifold isnt leaking, i fixed it a while back with some sort of clamp which seems to be holding just fine (i did find the old broken manifold stud when the downpipe came off though lol :)

only other thing to remark on is I had an aftermarket BOV fitted to it a short while back. The noise was doing my head in so i put the stock one back on and now under high boost i can hear the stock bov discharge? Im sure before it was silent? No hoses appear to be missing

Anyone have and ideas what else i can check?

cheers
Technohedge
Toyspeed Member
 
Posts: 41
Joined: Wed Mar 30, 2016 7:59 am

Re: Caldina GTT not boosting properly

Postby GDII » Mon Sep 11, 2017 10:55 am

How have you installed the stock BOV? They don't tend to work like aftermarket ones. At idle they suck in air through the outlet rather than seal like aftermarket ones. Not that this is your problem.
Maybe the diaphragm is torn.
1990 SW20 MR2
Previous 1990 EE90 Corolla
User avatar
GDII
Toyspeed Member
 
Posts: 1570
Joined: Wed Aug 22, 2007 4:13 pm
Location: Wellington

Re: Caldina GTT not boosting properly

Postby Technohedge » Mon Sep 11, 2017 9:29 pm

The BOV does appear to be sealing properly. Ive just put it back in the stock configuration where it vents into the airbox. When I take it off and rev the engine it shuts and seems to not let any air through from what I can feel.
Technohedge
Toyspeed Member
 
Posts: 41
Joined: Wed Mar 30, 2016 7:59 am

Re: Caldina GTT not boosting properly

Postby Technohedge » Tue Sep 12, 2017 9:41 pm

The Tvsv does appear to be doing its job as well. even if I disconnect the hose to it (running 'infinite' boost) it dosent accllerate with the same kick as it used to.

maybe a leak somewhere?
Technohedge
Toyspeed Member
 
Posts: 41
Joined: Wed Mar 30, 2016 7:59 am

Re: Caldina GTT not boosting properly

Postby whynot » Wed Sep 13, 2017 1:38 pm

Something to check could be the knock sensor then. Didn't the 3sgte have issues with the knock sensor pulling power?
"You can't do it like that!." "Why not?"
User avatar
whynot
Toyspeed Member
 
Posts: 390
Joined: Thu Apr 23, 2009 6:56 pm
Location: Manawatu

Re: Caldina GTT not boosting properly

Postby Technohedge » Thu Sep 21, 2017 12:45 pm

Possibly, is there any info on how to 'check' these?

cheers
Technohedge
Toyspeed Member
 
Posts: 41
Joined: Wed Mar 30, 2016 7:59 am

Re: Caldina GTT not boosting properly

Postby Mr Revhead » Sun Sep 24, 2017 7:46 pm

A faulty knock sensor should show a CEL, code 52 iirc.

Have a look at this thread if you suspect the BOV
viewtopic.php?t=32156&postdays=0&postorder=asc&start=20
Being the subject of E-whinges since 2004 8)

http://www.centralmotorsport.org.nz/home

Image
User avatar
Mr Revhead
SECURITY!
 
Posts: 24623
Joined: Tue Jan 20, 2004 4:06 pm
Location: Nelson


Return to Tech Questions

Who is online

Users browsing this forum: No registered users and 5 guests

Fatal: Not able to open ./cache/data_global.php