Bad miss under acceleration 2002 corolla

The place for all technical car discussions. If you haven't already, read our Disclaimer first!

Moderator: The Mod Squad

Bad miss under acceleration 2002 corolla

Postby RAZA » Thu Jun 13, 2019 8:30 am

Hi team,
I have a 2002 corolla (e120?) With the 1.5L engine.
It has developed a fairly bad miss under acceleration between 1000 & 3000rpm. It idles fine, and once past 3000 it is fine.
It improves once the car is up to temp, but It's particularly bad for the first 5 minutes after a warm start.

Google and my guess agree there are a few possible causes.
- afm
- o2 sensor
- fuel supply (pump/pressure regulator etc?)
-plugs etc

Rather than start replacing these 1 by 1 and inevitably find out the problem is the last thing I replace, does anyone have any suggestions on how to isolate the problem?

Tia
Currently driving:

BMW 135i M
User avatar
RAZA
Toyspeed Member
 
Posts: 850
Joined: Mon May 20, 2002 9:43 pm
Location: Auckland

Re: Bad miss under acceleration 2002 corolla

Postby GDII » Thu Jun 13, 2019 6:55 pm

Coils can give up on these engines. I assume it's the 1NZFE based on the 1.5litre capacity.

Spark plugs are good to just replace anyway. You can pick between the 5 types of DENSO or NGK
http://www.globaldenso.com/cgi-bin/glob ... ion=search
https://www.ngk.com/product.aspx?zpid=9326
1990 SW20 MR2
Previous 1990 EE90 Corolla
User avatar
GDII
Toyspeed Member
 
Posts: 1636
Joined: Wed Aug 22, 2007 4:13 pm
Location: Wellington

Re: Bad miss under acceleration 2002 corolla

Postby xsspeed » Sat Jun 15, 2019 11:38 am

Sounds symptomatic of failing coil(s)
Are these coil on plug?
xsspeed
Toyspeed Member
 
Posts: 3946
Joined: Tue Aug 21, 2007 5:56 pm
Location: Auckland

Re: Bad miss under acceleration 2002 corolla

Postby RAZA » Mon Jun 17, 2019 4:27 pm

Thanks for the replies. It is the 1nzfe.

Any suggestions on how to check the coil packs? unplugging them one at a time while at idle doesn't tell me anything as it runs fine at idle. Am trying to avoid buying new ones then finding the fault lies elsewhere.
Currently driving:

BMW 135i M
User avatar
RAZA
Toyspeed Member
 
Posts: 850
Joined: Mon May 20, 2002 9:43 pm
Location: Auckland

Re: Bad miss under acceleration 2002 corolla

Postby matt dunn » Mon Jun 17, 2019 11:52 pm

Going from your explanation it really sounds like a failing coil.
They are hard to tell which one though.

Sometimes it is just as easy to get one, fit it to cyl 1 and try it.
If not fixed try cyl 2, then 3 then 4 etc.

OR see if there is a fault code in the system,
possibly not though from a coil fault.
7AGTE - DX20VT - viewtopic.php?t=59733
Discussion - viewtopic.php?t=59751
matt dunn
Toyspeed Member
 
Posts: 7101
Joined: Fri Sep 12, 2003 1:01 am
Location: Timaru

Re: Bad miss under acceleration 2002 corolla

Postby RAZA » Tue Jun 18, 2019 8:18 am

Ok cheers will get hold of a coil and give that a go.
Currently driving:

BMW 135i M
User avatar
RAZA
Toyspeed Member
 
Posts: 850
Joined: Mon May 20, 2002 9:43 pm
Location: Auckland


Return to Tech Questions

Who is online

Users browsing this forum: Google [Bot] and 9 guests

Fatal: Not able to open ./cache/data_global.php