1NZ VVTI Idling rough

The place for all technical car discussions. If you haven't already, read our Disclaimer first!

Moderator: The Mod Squad

1NZ VVTI Idling rough

Postby evil_evo » Wed Jan 13, 2021 11:21 am

Hello All,

I have a Toyota Auris 2006 engine 1NZ Chassis NZE151-1000394 VVTI.
Recently I noticed that engine idling roughly and I can also see that once car is warmed idling between 600-500 RPM ( mostly stays around 600 however it does drop a little maybe 580 and then goes back to 600). I have no engine light but I can see air filer area is vibrating roughly.

So I did the following
I scanned the car using ODB2 scanner - no code found
just to make sure my scanner is using I unplugged the MAF sensor and surely enough scanner picked that up so scanner is working
Car does have an electrical throttle body - I took that a apart and cleaned it ( it wasnt that dirty )
I also cleaned the MAF sensor
I checked for vacuum leak - I did my best looking for any leak but I couldn't see much

I am kinda new to this and I was trying to figure out where is idle control valve, sometime this can be the issue ? OR the Engine Variable Valve Timing (VVT) Solenoid ?
Can someone please let me know where are these components are located ? If anyone has any diagram please let me know. OR Can anyone here help me would might be the issue or what to check next please ?
Thanks in advance.
evil_evo
Toyspeed Member
 
Posts: 17
Joined: Mon Apr 02, 2012 1:26 pm

Return to Tech Questions

Who is online

Users browsing this forum: No registered users and 1 guest