3sgte boost creep

The place for all technical car discussions. If you haven't already, read our Disclaimer first!

Moderator: The Mod Squad

3sgte boost creep

Postby Bruz512 » Tue Jun 27, 2017 1:07 pm

Hey guys, i'm new to the Toyota life and was looking for some advice.
I recently started experiencing boost creep in my GTT Caldina when my boost controller is on. I started noticing it after finding a rather large crack in the dump pipe coming off the turbo.
I've had the dump pipe and some other parts of the exhaust replaced and there are now no leaks, however I still experience boost creep when using the controller. With it turned off and running stock boost, it holds pressure fine.
Any ideas of what could cause this? The controller is a Turbosmart eboost street, I've done a visual inspection and can't find any leaks in the controller's lines.
Cheers in advance! :D
Bruz512
Toyspeed Member
 
Posts: 6
Joined: Fri Jun 23, 2017 9:40 am

Re: 3sgte boost creep

Postby BlakeNZ » Tue Jun 27, 2017 11:24 pm

how much boost you running with it "on" and "off"?
JZZ30 soarer 1JZGTE 11.5sec@122mph(stock turbos,E85)
BlakeNZ
Toyspeed Member
 
Posts: 597
Joined: Thu Oct 03, 2002 1:53 pm
Location: Palmerston Nth

Re: 3sgte boost creep

Postby Bruz512 » Wed Jun 28, 2017 8:46 am

Hi,
With it off, it runs factory boost which is around 7.5psi (going by my boost gauge). When its on it has 2 boost settings, one at 9psi and one at 13. I barely use the higher boost setting, but i get boost creep on either setting, up to 19psi.
Bruz512
Toyspeed Member
 
Posts: 6
Joined: Fri Jun 23, 2017 9:40 am

Re: 3sgte boost creep

Postby Mr Ree » Tue Jul 11, 2017 5:19 pm

Im not familiar with that EBC but typically, they all have the same features. Have you played around with the duty setting?
wak thud gush!
User avatar
Mr Ree
Toyspeed Member
 
Posts: 2747
Joined: Wed Nov 17, 2010 6:51 pm
Location: On the South coast where the tui's sing tututu.

Re: 3sgte boost creep

Postby Bruz512 » Thu Jul 13, 2017 2:07 pm

I'm not too familiar myself, hence why I'm here :p
I haven't really touched any of the settings on it to be honest, the guy I bought it off said it was tuned by the installer and he never touched it. It's only a recent issue, so i didn't think changing the settings would help, as it ran fine for at least the first 2 months I owned it.
This is my first car with an electronic boost controller, and I'm still learning about it to be honest, in regards to what all the settings actually do etc. If my understanding is correct (and it may not be), the duty setting is called the 'Set Point' on this model, and controls the duty cycle of the solenoid, if that sounds correct? You think maybe lowering this value, and hence opening the wastegate earlier, might help?
Bruz512
Toyspeed Member
 
Posts: 6
Joined: Fri Jun 23, 2017 9:40 am

Re: 3sgte boost creep

Postby whynot » Thu Jul 13, 2017 9:34 pm

I have seen something similar to this before. The issue is the factory waste gate in a CT series turbo is only just big enough to cope with a standard exhaust and boost levels. If you up the boost or free up the exhaust then you tend to run into boost creep. If that is the case then I would look into porting out the waste gate if you don't want to do much more engine mods or look at a different turbo setup.
"You can't do it like that!." "Why not?"
User avatar
whynot
Toyspeed Member
 
Posts: 411
Joined: Thu Apr 23, 2009 6:56 pm
Location: Melbourne

Re: 3sgte boost creep

Postby Bruz512 » Fri Jul 14, 2017 9:01 am

I thought it might be a wastegate issue, but the only thing causing me to doubt it is the exhaust. It hasn't changed. Yes it's a new system, but its all the same sizing as the old system (someone had already installed a 3'' system) so theres no increase in flow. The only difference is that there's now no cracks in the system. The boost creep only started when the crack appeared.
By all means it could be the wastegate. Like I mentioned, it's not really my area of expertise. Is there anyway to determine exactly if that is the issue?
Bruz512
Toyspeed Member
 
Posts: 6
Joined: Fri Jun 23, 2017 9:40 am

Re: 3sgte boost creep

Postby whynot » Fri Jul 14, 2017 1:33 pm

I'm not sure on how to prove that it is the waste gate entirely. You could try to increase back pressure on the exhaust by restricting it which would mimick the factory exhaust and if the creep went away then you could say the exhaust is part of the problem. Other option would be to fit a basic boost tee and turn the boost up a little from stock and see if it creeps. If it doesn't then it would suggest problems in the boost controller. Or you could remove the turbo and attack the waste gate port with a diegrinder and see if that helps fix it.
"You can't do it like that!." "Why not?"
User avatar
whynot
Toyspeed Member
 
Posts: 411
Joined: Thu Apr 23, 2009 6:56 pm
Location: Melbourne

Re: 3sgte boost creep

Postby Bruz512 » Fri Jul 14, 2017 3:19 pm

Not a bad idea, I might look into both of those. I'm not overly stressed, as stock boost runs fine and I really dont NEED to turn the boost up (even though the option would be nice). I was just more concerned that it may have been a symptom of a larger problem.
Thanks for your replies! :)
Bruz512
Toyspeed Member
 
Posts: 6
Joined: Fri Jun 23, 2017 9:40 am

Re: 3sgte boost creep

Postby Bruz512 » Fri Mar 16, 2018 8:46 am

Not sure if anyone is still following this, I forgot to post when I solved the issue. Basically the aftermarket solenoid hooked up to the boost controller was blocked with carbon buildup. This meant it wasn't reading pressure from the turbo correctly and hence not signalling the wastegate to open, essentially I was free boosting! Cleaned it out about7 months ago and haven't had an issue since.
Bruz512
Toyspeed Member
 
Posts: 6
Joined: Fri Jun 23, 2017 9:40 am

Re: 3sgte boost creep

Postby whynot » Fri Mar 16, 2018 2:15 pm

Good to hear you figured it out. Now that you mention carbon build up perhaps I should check my solenoid. It's not something you would think of cleaning out very often.
"You can't do it like that!." "Why not?"
User avatar
whynot
Toyspeed Member
 
Posts: 411
Joined: Thu Apr 23, 2009 6:56 pm
Location: Melbourne


Return to Tech Questions

Who is online

Users browsing this forum: No registered users and 5 guests

Fatal: Not able to open ./cache/data_global.php