4age 20v trigger link g4

The place for all technical car discussions. If you haven't already, read our Disclaimer first!

Moderator: The Mod Squad

4age 20v trigger link g4

Postby mega4a » Sat Jul 15, 2017 8:04 pm

wired in a g4 storm link ecu with a nzefi base tune.

im just wondering if anyone could shed some light on which pin trigger 2 should go to. ive been abit confused with which one is correct

trigger 1 is ne
trigger 2 is g1
nothing goes to G2
ground GND

so i had trigger 2 wire to G2 at first and was getting rpm and but to get 10 degrees on the timing light i had to set the trigger offset to 210 it started at -5 from nzefi basemap now the car seemed like it wanted to start but wouldnt and having the trigger offset set on the computer too 210 got my thinking the wiring was backwards.

so iv have changed trigger two to G1 but my car batt is flat so giving up for the night.

just wanting to know what have ppl with link ecu done in the past how have you guys wired the dizzy?
DAILY DRIVEN.
230HP ATFW AE100 WAGON 4AFTE MEGASQUIRT.
1999 Toyota Corolla BZ Touring wagon 4age 20v bt.
1996 Toyota Truneo 5AFE
User avatar
mega4a
Toyspeed Member
 
Posts: 263
Joined: Sat Feb 19, 2011 5:51 pm
Location: Auckland

Re: 4age 20v trigger link g4

Postby 85AW20v » Sat Jul 15, 2017 10:16 pm

I just put this into Google and came up with heaps of info - Link G4 ECU 20v trigger wiring. Give that a go.
See ya

Simon
85 MR2 20v
User avatar
85AW20v
Toyspeed Member
 
Posts: 1052
Joined: Fri May 24, 2002 6:18 pm
Location: Taupo, NZ

Re: 4age 20v trigger link g4

Postby whynot » Sat Jul 15, 2017 11:47 pm

I have a 4age 20v with a g4 storm

From what I remember of the wiring your first setup was correct but trigger two could work on either signal if you set the trigger offset to suit.

Some base settings I took off my ecu.

Trigger one is set to reluctor, cam, 24 tooth
Trigger two is set to reluctor, cam pulse 1x

Arming threshold for both triggers. (rpm/volts)
0/0.5. 1000/1.0. 2000/1.5. 3000/2.0. 4000/2.5. 5000/3.0. 6000/3.5. 7000/3.5.


Trigger offset is - 13 deg

I suspect yours may be trying to fire on the exhaust stroke, either that or you are using the second pulse signal from the dizzy

The flat battery may be sabotaging your attempts to start the car especially if the injector dead time is not set correctly.

Mine is set to the below but I have 800cc injectors so it could be miles out, however if it gets the motor started. Then you can tweak the settings for your injectors.

(batt voltage/dead time)
6/2.400. 7/2.200. 8/1.800. 9/1.400. 10/1.200. 11/1.100. 12/0.990. 13/0.870. 14/0.820. 15/0.700.

Also if you have had the dizzy apart (fixing oil leak perhaps) then the air gap between the pick up and the toothed gear in the dizzy is critical, get the feeler gauge out if you have had it apart.
"You can't do it like that!." "Why not?"
User avatar
whynot
Toyspeed Member
 
Posts: 411
Joined: Thu Apr 23, 2009 6:56 pm
Location: Melbourne

Re: 4age 20v trigger link g4

Postby mega4a » Sun Jul 16, 2017 9:25 am

Thanks whynot now that's the kinda help I was looking for!

Yes I think you are right it's trying to fire on the wrong stroke.

I have changed the wiring to G1 and I'll use a timing light to get it back to 10 degrees by changing the trigger offset.

I also have 750cc sards so I'll look into that and have abit of a fiddle around sew how it goes.

Cheers man thanks heaps. I might need to hustle yah mixture map if I can the nzefi one seems to be way out.
DAILY DRIVEN.
230HP ATFW AE100 WAGON 4AFTE MEGASQUIRT.
1999 Toyota Corolla BZ Touring wagon 4age 20v bt.
1996 Toyota Truneo 5AFE
User avatar
mega4a
Toyspeed Member
 
Posts: 263
Joined: Sat Feb 19, 2011 5:51 pm
Location: Auckland


Return to Tech Questions

Who is online

Users browsing this forum: No registered users and 6 guests

Fatal: Not able to open ./cache/data_global.php